• Join

Upgrade Your Vidyo Endpoints and Web Browsers for TLS Version 1.2 Compatibility



The PCI Security Standards Council recommends all IT organizations upgrade to Transport Layer Security (TLS) version 1.2 due to widely known security vulnerabilities with versions 1.0 and 1.1.  To adhere to this standard, Join’s infrastructure team is requiring that Vidyo endpoints and web browsers support the TLS 1.2 protocol for connection to Joinvideo services as of April 30, 2019.

Consequently, you must upgrade your endpoints and web browsers to the minimum or later versions required by Vidyo in order to:

Maintains your connectivity to Joinvideo services.Protects your online communication from malicious outside forces.Adheres to the latest protocol recommended by the PCI Security Standards Council. 

Join encourages you to forward this communication to the appropriate resources within your organization as we are eager to get this information to the right people, as soon as possible, to avoid any service interruptions. 


What Do I Need to Do? 

To prevent connectivity issues, you must upgrade your Vidyo endpoints and web browsers as follows by April 30, 2019.  

Upgrade your Vidyo endpoints to the minimum or latest version by referring to the Vidyo Endpoints Minimum and Latest Versions Table article. Upgrade your web browsers at least to the minimum version: Microsoft® Internet Explorer 10 and laterMozilla® Firefox 23 and laterGoogle™ Chrome 40 and later Apple® Safari 7 and later

Note: If you do not upgrade your web browser(s) to a version that supports TLS 1.2, you will be restricted from accessing the Tenant Admin, Room Link, and Control Meeting pages. 


#Videoconference #JoinVideo

1 visualizzazione

© 2019 by JoinConferencing

  • White Twitter Icon
  • White Linkedin icon
  • White Facebook Icon